Netbeans 7.2.1 und Glassfish 3.1.2 deploy Problem

Allgemeine Themen rund um dem Appl.-Server GlassFish

Moderator: wegus

Antworten
peters
Beiträge: 2
Registriert: 31.10.2012, 09:20

Netbeans 7.2.1 und Glassfish 3.1.2 deploy Problem

Beitrag von peters » 31.10.2012, 09:29

Hallo,

ich bin neu hier im Forum und habe gleich mal eine Frage:

Eine kleine Web-Testanwendung mit JSF soll mit Netbeans an Glassfish deployed werden. Auf einem PC mit Win7 funktioniert das auch ohne Probleme. Auf einem Windows 2008 R2 Server (64-bit, mit Service Pack 1) klappt das irgendwie nicht.
Folgende Meldungen werden in Netbeans angezeigt:

Launching GlassFish on Felix platform
INFO: Running GlassFish Version: GlassFish Server Open Source Edition 3.1.2.2 (build 5)
INFO: Registered org.glassfish.ha.store.adapter.cache.ShoalBackingStoreProxy for persistence-type = replicated in BackingStoreFactoryRegistry
INFO: Grizzly Framework 1.9.50 started in: 0ms - bound to [0.0.0.0:3700]
INFO: Grizzly Framework 1.9.50 started in: 15ms - bound to [0.0.0.0:4848]
INFO: Grizzly Framework 1.9.50 started in: 62ms - bound to [0.0.0.0:8080]
INFO: Grizzly Framework 1.9.50 started in: 31ms - bound to [0.0.0.0:8181]
INFO: Grizzly Framework 1.9.50 started in: 16ms - bound to [0.0.0.0:7676]
INFO: The Admin Console is already installed, but not yet loaded.
INFO: GlassFish Server Open Source Edition 3.1.2.2 (5) startup time : Felix (2,934ms), startup services(1,196ms), total(4,130ms)
INFO: Created EjbThreadPoolExecutor with thread-core-pool-size 16 thread-max-pool-size 32 thread-keep-alive-seconds 60 thread-queue-capacity 2147483647 allow-core-thread-timeout false
INFO: Initiating Jersey application, version 'Jersey: 1.11.1 03/31/2012 06:49 PM'
INFO: REST00001: Listening to REST requests at context: /management/domain
INFO: The Admin Console is already installed, but not yet loaded.
INFO: The Admin Console is starting. Please wait.
INFO: WEB0169: Created HTTP listener [http-listener-1] on host/port [0.0.0.0:8080]
INFO: WEB0169: Created HTTP listener [http-listener-2] on host/port [0.0.0.0:8181]
INFO: WEB0169: Created HTTP listener [admin-listener] on host/port [0.0.0.0:4848]
INFO: WEB0171: Created virtual server [server]
INFO: WEB0171: Created virtual server [__asadmin]
INFO: JMX005: JMXStartupService had Started JMXConnector on JMXService URL service:jmx:rmi://DEDCW28SAN02.de.int.kaufland:8686/jndi/rmi://DEDCW28SAN02.de.int.kaufland:8686/jmxrmi
INFO: WEB0172: Virtual server [server] loaded default web module []
INFO: SEC1002: Security Manager is OFF.
INFO: SEC1010: Entering Security Startup Service
INFO: SEC1143: Loading policy provider com.sun.enterprise.security.provider.PolicyWrapper.
INFO: SEC1115: Realm [admin-realm] of classtype [com.sun.enterprise.security.auth.realm.file.FileRealm] successfully created.
INFO: SEC1115: Realm [file] of classtype [com.sun.enterprise.security.auth.realm.file.FileRealm] successfully created.
INFO: SEC1115: Realm [certificate] of classtype [com.sun.enterprise.security.auth.realm.certificate.CertificateRealm] successfully created.
INFO: SEC1011: Security Service(s) Started Successfully
INFO: Initializing Mojarra 2.1.6 (SNAPSHOT 20111206) for context ''
INFO: HV000001: Hibernate Validator 4.3.0.Final
INFO: WEB0671: Loading application [__admingui] at [/]
INFO: CORE10010: Loading application __admingui done in 8,032 ms
INFO: The Admin Console application is loaded.

Nach der letzten Meldung ist Ende und nach ca. 20 Minuten kommt ein Timeout. Eine Fehlermeldung habe ich bisher nicht gefunden.
Richte ich das ganze per Hand in Glassfish ein, funktioniert alles bestens.
Die Admin-Console von Glassfish wird gestartet, anscheinend funktioniert der deploay-Mechanismus nicht.

Was könnte die Ursache hierfür sein?

Gruß

Peter

peters
Beiträge: 2
Registriert: 31.10.2012, 09:20

Re: Netbeans 7.2.1 und Glassfish 3.1.2 deploy Problem

Beitrag von peters » 31.10.2012, 10:17

So, ich antworte mal auf mein eigenes Problem.

Ich habe doch noch eine Fehlermeldung in Netbeans gefunden und zwar unter View->IDE Log.
Die Meldung deutete auf eine falsche Konfiguration der Proxy-Einstellungen hin. Und tatsächlich waren die Parameter falsch.
Nach der Korrektur funktioniert jetzt alles bestens!


Gruß

Peter

Benutzeravatar
smurfi
Site Admin
Beiträge: 1629
Registriert: 29.06.2006, 11:33
Wohnort: Wuppertal
Kontaktdaten:

Re: Netbeans 7.2.1 und Glassfish 3.1.2 deploy Problem

Beitrag von smurfi » 31.10.2012, 17:09

Hallo und Danke für die Antwort....

Gruß
Michael

Antworten